Service disruption
Resolved
May 20, 2026 at 1:41am UTC
Service has been fully restored. We are in the process of rerunning all failed document processing executions. ETA for completion is 15 minutes.
We will provide further information about the cause of the incident, and future mitigations we plan to implement ASAP.
Affected services
Updated
May 20, 2026 at 1:11am UTC
Most funcionality within Caresquare has now been restored. Please note invoice ingestion is still currently down and we are working to have this resolved ASAP.
Affected services
Updated
May 19, 2026 at 11:34pm UTC
The root cause of the issue has been identified by our upstream service provider and a fix is expected to be deployed shortly.
Affected services
Created
May 19, 2026 at 11:28pm UTC
One of our upstream cloud server providers is experiencing an outage that is affecting some functionality in the Caresquare application.
They have advised the issue has been identified and they are rolling out a fix.
We are monitoring and will advise once normal service is restored.
Affected services